メイン Pc & マック 電子メールは大文字と小文字を区別しますか?

電子メールは大文字と小文字を区別しますか?



電子メール アドレスで大文字と小文字が区別されるかどうかについては、多くの混乱があります。あると言う人もいれば、そうではないと主張する人もいます。では、誰が正しいのでしょうか?この記事では、メールアドレスが大文字と小文字を区別するか区別しないかについて見ていきます。

電子メールは大文字と小文字を区別しますか?

メールアドレスを作るものは何ですか?

電子メール アドレスは、ローカル部分 (ユーザー名とも呼ばれます)、@ 記号、およびドメイン部分の 3 つの部分で構成されます。各パートには独自の役割があり、独自のルール セットが適用されます。簡単な概要を次に示します。

標準によると、電子メール アドレスのローカル部分は最大 64 文字の長さで、限られた文字セットで構成できます。これには、大文字と小文字のラテン アルファベット、0 から 9 までの数字、ドット、および特殊文字が含まれます。特殊文字には、` [email protected] #$%^&*()_-+=[]{}~ が含まれます。 @ 記号でドメイン部分に接続します。

ドメイン部分の長さは最大 255 文字です。ラテン アルファベット (小文字と大文字の両方)、0 から 9 までの数字、およびハイフンを含めることができます。ハイフンでドメイン部分を開始または終了することはできません。

後で詳しく説明しますが、国際記号も使用できます。

大文字と小文字は区別されますか?

この質問に対する正しい答えは、イエスでもありノーでもあります。による RFC 5321 、電子メール アドレスのローカル部分では大文字と小文字が区別されます。これは、理論上、[email protected] と [email protected] は同じではないことを意味しますが、メール プロバイダーはローカル部分を大文字と小文字を区別するものと区別しないものの両方として扱う自由があります。

たとえば、 [email protected] 、 [email protected] 、および [email protected] は、理論的には異なるメール アドレスです。メールサーバーがローカル部分を大文字と小文字を区別して扱うことを選択した場合、これがどのように問題を引き起こし、ユーザーエクスペリエンスを低下させるかは簡単に理解できます。したがって、多くのプロバイダーは、電子メール アドレスのローカル部分を大文字と小文字を区別しないものとして扱います。

アマゾンファイヤースティックでグーグルプレイ

ドメイン部分については、 RFC1035 常に大文字と小文字を区別しないことを規定しています。これは、小文字、大文字、またはそれらの任意の組み合わせで書くことができ、あなたのメールは同じアドレスに届くことを意味します。実際には、[email protected] と [email protected] と [email protected] は同じメールアドレスです。

実際には

電子メール アドレスでは大文字と小文字が部分的にしか区別されませんが、通常は大文字と小文字を区別しないと考えても安全です。 Gmail、Yahoo Mail、Hotmail などの主要なプロバイダーはすべて、メール アドレスのローカル部分を大文字と小文字を区別しないものとして扱います。そうは言っても、メールの作成に使用するメール プロバイダーのルールを確認する必要があります。

上記の点に関連して、上記の RFC 5321 では、潜在的な混乱と配信の問題を回避するために、新しい電子メール アドレスは小文字のみで作成することを推奨しています。

逆に、友達や同僚が大文字と小文字を組み合わせたメールアドレスを持っている場合は、そのままメールを送るのが賢明です。そうしないと、メールが配信されない場合があります。ただし、これは、Gmail、Yahoo Mail、Hotmail などの主要なメール プロバイダーの問題ではありません。

さらに、Gmail は、ユーザー アカウントの識別に関して、メールのローカル部分にあるドットの影響も受けません。つまり、[メール保護]アカウントが存在する場合、[メール保護]や[メール保護]を登録することはできません。

国際化

もともと、電子メール アドレスは、ラテン アルファベットの文字、数字、および限定された一連の特殊な ASCII 文字を使用してのみ登録できました。しかし IETF (Internet Engineering Task Force) はその後、国際的な文字を含めるためのルールと標準を開発しました。

RFC6530 は、国際文字の使用を含めて規制した最初の企業です。 RFC6531 ルールと基準を拡張しました。その後、規則と基準は、 RFC6532 そして RFC6533 .

幅広いアルファベット、文字、スクリプトでメールアドレスを登録できるようになりました。最も広く使用されているものには、発音記号付きのラテン文字、ギリシャ文字、繁体字中国語文字、日本語文字 (ひらがな、カタカナ、漢字)、キリル文字、いくつかのインド文字、その他のさまざまな文字が含まれます。

国際電子メール アドレスの包含と互換性は、プロバイダーによって異なります。最大のプロバイダーの一部でさえ、国際アドレスと完全に互換性がありません。たとえば、Google では国際アドレスにメールを送信できますが、作成することはできません。 Outlook 2016 にも同様の機能があります。

結論

ドメイン名の部分とは異なり、メール アドレスのローカル部分では大文字と小文字が区別されます。そうは言っても、多くの電子メール プロバイダーは、実用的な理由からローカル部分の大文字と小文字の区別を無視し、小文字のみで電子メールを作成するように人々に勧めています。

興味深い記事

エディターズチョイス

OBS Studio を使用した Twitch ストリーミングの初心者ガイド
OBS Studio を使用した Twitch ストリーミングの初心者ガイド
わかりやすいガイドに従って、OBS Studio を使用した Twitch ストリーミングをわずか 30 分で開始できます。アラートや画像などをストリームに追加する方法を学びます。
Windows10でデスクトップアイコンを小さくする方法
Windows10でデスクトップアイコンを小さくする方法
Windowsの最も優れた点の1つは、Windowsをほぼ無限にカスタマイズして、思いどおりの外観と感触を実現できることです。デフォルト設定はかなり良いですが、常に改善の余地があります。だから、どうやって
Amazon Fire StickでHBOを解約する方法
Amazon Fire StickでHBOを解約する方法
ほとんどの人は、HBO が The Sopranos、The Wire、Game of Thrones など、数多くの素晴らしいオリジナルの番組を持つ素晴らしいチャンネルであり、リストは続きます。どれも評価の高いドラマなので、
Mac OSXプレビューでPDFドキュメントからページを抽出する方法
Mac OSXプレビューでPDFドキュメントからページを抽出する方法
OS Xのプレビューアプリは、ページの再配置や削除、メタデータの変更など、PDFドキュメントの基本的な変更を実行できる強力なツールです。あまり知られていない可能性のある機能の1つは、既存のPDFドキュメントから1つ以上のページを抽出する機能です。それを行うための2つの方法を学ぶために読んでください。
黒曜石ジャーナル テンプレート
黒曜石ジャーナル テンプレート
メモ作成アプリの Obsidian は、ゼロから始めなくても日記を構造化する優れた方法となるテンプレートを利用しています。完璧な黒曜石日記テンプレートを見つけるのが難しい場合は、ここが最適です。
マックス: 内容と視聴方法
マックス: 内容と視聴方法
オリジナル番組に加えて、HBO とワーナーメディアの両方のコンテンツを提供するストリーミング サービス、Max について学びましょう。
Windows10で仮想デスクトップを削除する
Windows10で仮想デスクトップを削除する
Windows10で仮想デスクトップを削除する方法Windows10には、タスクビューと呼ばれる便利な機能が付属しています。これにより、ユーザーは仮想デスクトップを使用できるようになります。